Transparentes PNG Bild ist milchig grau
#1
Hallo,
für eine Homepage benötige ich ein schwarzes Rechteck (PNG Bild) mit 50% Deckkraft. Also habe ich dies (in Corel Photo Paint X4) erstellt, das Objekt auf 50% Deckkraft eingestellt und als PNG Bild abgespeichert. Hole ich mir dieses Bild nun und lege es über ein Foto, so ist dies nicht schwarz mit 50% Deckkraft, sondern grau (mit wahrscheinlich 50% Deckkraft). 

Warum?

Links das "echte" Objekt in PP, rechts das davon erstellte, eingefügte PNG Bild.


Angehängte Dateien Thumbnail(s)
   
Zitieren
#2
(17.02.2019, 11:29)visionbrasil schrieb: Hallo,
für eine Homepage benötige ich ein schwarzes Rechteck (PNG Bild) mit 50% Deckkraft. Also habe ich dies (in Corel Photo Paint X4) erstellt, das Objekt auf 50% Deckkraft eingestellt und als PNG Bild abgespeichert. Hole ich mir dieses Bild nun und lege es über ein Foto, so ist dies nicht schwarz mit 50% Deckkraft, sondern grau (mit wahrscheinlich 50% Deckkraft). 

Warum?

Links das "echte" Objekt in PP, rechts das davon erstellte, eingefügte PNG Bild.

Nun, müßte man wissen, was Du genau gemacht hast. Du hast z.B. für das schwarze Rechteck ein CMYK-Schwarz verwendet. Je nach Einstellung der Farbverwaltung wird das nach Konvertierung zu RGB grau. Und im PNG gibts nunmal kein CMYK. Das halte ich für den wahrscheinlichsten Grund und einerseits solltest Du die Farbverwaltung sinnvoll einstellen, andererseits für diesen Zweck RGB-Schwarz verwenden, damit es erst gar nicht konvertiert werden muß.

Hier eine Hilfe für die Farbverwaltung:
https://forum.juergens-workshops.de/show...?tid=36855

Betriebssystem / Grafik-Software: Windows 7, Corel X6, Adobe-Suite CS3, CS6, Lightroom 5
Zitieren
#3
Hallo Visionbrasil,
über die möglichen Gründe hat MVM schon geschrieben.

Für Deine absolute Zufriedenheit und eine korrekte Webseite würde ich Dir aber das Anlegen der Transparenz in CSS vorschlagen.

Viele Grüße, Chris

Betriebssystem / Grafik-Software: Win 7
Zitieren
#4
Also das Bild ist in RGB aufgebaut worden und wurde auch so in PNG exportiert.
Nachdem ich keine Lösung in PP gefunden hatte, habe ich mir GIMP heruntergeladen. Und siehe da, 3 klicks und schon hatte ich das Bild in PNG ohne Farbverfälscchung.
Problem gelöst ......allerdings nicht via PP  Sad
Zitieren
#5
Klar, weil Gimp kein CMYK kann. Die Farbpalette, die Du für das schwarze Rechteck in PhotoPaint verwendet hast, ist eine CMYK-Palette. Da nützt es nichts, wenn Du das Bild an sich in RGB definiert hast. In dem Moment, in dem die CMYK-Farbe übersetzt wird nach RGB, wird aus schwarz grau. Aber auch nur, weil Deine Farbverwaltung falsch eingestellt hast. Wie bereits erwähnt. Sorry, wenn das kompliziert ist, aber da kann PhotoPaint nichts dafür.

Betriebssystem / Grafik-Software: Windows 7, Corel X6, Adobe-Suite CS3, CS6, Lightroom 5
Zitieren
#6
In der Tat ist mir das zu "hoch"....... 

Wenn ich ein RGB 24 bit Bild habe bzw. neu erstelle, und dieses dann auch so speichere (sofern das Ausgabeformat es auch kann, was bei PNG ja der Fall ist) WO und WANN bitte soll da dann was konvertiert werden?????????
Oder gibt es da irgendwo kleine grüne Männchen im Programm sie das von alleine machen?


Angehängte Dateien Thumbnail(s)
   
Zitieren
#7
Habe jetzt den Link MVM gelesen. 
Hummmm in dieser Farbverwaltung war ich noch nie drin. Verstehe es auch nicht ganz - insbesondere weil es bei mir ganz anders aussieht wie in dem Beitrag. Und so wie ich das verstehe geht es da vor allem um den Druck bzw. der Darstellung der Farben auf dem Bildschirm !?! Und das sah bei mir ja auch immer ganz gut aus. 

Hatte auch noch nie Probleme bei (JPG) Fotos, dass da "Falschfarben" ausgegeben worden wären.
Erst jetzt mit diesen transparenten PNG gibt es Probleme. 
Würde ja schon gerne alles über ein Programm machen statt nur wegen diesem Problem Gimp noch zu behalten.

Was ist denn an der Einstellung bei mir falsch?


Angehängte Dateien Thumbnail(s)
   
Zitieren
#8
Hallo,
Farbverwaltung ist ein umfängliches Thema, lies dir den ganzen Thread durch.
Ab X5 schaut und arbeitet die Farbverwaltung auch anderst, du musst in dem von Martin verlinkten Thread einen Beitrag weiter runter zu X4
https://forum.juergens-workshops.de/show...#pid161422

Ich habe jetzt X4 nicht mehr genau im Kopf, aber probiere mal in der Farbverwaltung oben bei Einstellungen die Voreinstellung für "Web" zu nutzen

Gruß
Norre
Zitieren
#9
Hallo Norre,

Danke für dein Hilfe. Habe es mal auf Web eingestellt. Bringt aber keine Veränderung. 

Verstehe auch gar nicht was die Farbverwaltung soll - speziell für mein Problem. Auch nicht nachdem ich den Thread gelesen habe. Nach meinem Verständnis (nachdem ich den deutschsprachigen Teil des Thread gelesen habe) ist die Farbverwaltung doch nur zuständig für das Kalibrieren zwischen Bildschirm, Scanner, Kameras und Drucker und nicht wie das Bild abgespeichert wird.
Farbengines, Wiedergabeabs., Farbmetrik, Farbprofil, Druckprofil............ ????????????
"
.........man ja zusätzlich zur korrekten Pfeil-Setzung auch noch jeweils auf die Symbole selbst klicken, um dort die richtigen Profile einzustellen. Dies wiederum setzt Fachwissen voraus und damit hatte es sich mit der intuitiven Konfiguration."

Sorry, aber ich bin kein Grafiker........ich möchte nur ein einfaches, einfarbiges, transparentes PNG abspeichern nach dem Motto Input = Output.
Wenn ich also jetzt (Gott sei Gimp) ein 50% transparent Schwarz (RGB) PNG erstellen konnte, dies testweise mal in PP öffne, nicht verändere und nur erneut als PNG speichere, dann darf doch dabei nicht plötzlich ein 50% transparent Grau dabei rauskommen.

Wäre schön wenn es in PP auch so einfach gewesen wäre.

Wobei ich festgestellt habe, dass das Original von Gimp 13,6 KB hat, das von PP dann nur noch 248 Byte hat. Liegt da das Problem?


Angehängte Dateien
.png   Transparenz.png (Größe: 13,67 KB / Downloads: 58)
.png   Transparenz9.png (Größe: 248 Bytes / Downloads: 57)
Zitieren
#10
Hallo,
es sollte eigentlich auch in PP funktionieren.
So wie ich das in den Screenshot in deinem Beitrag #6 sehe ist dein Bild auch in RGB.
Ich komme auch gerade an mein X4 nicht ran, sonst könnte ich dir sagen ob es direkt an PP liegt oder an einer Einstellung.
Wenn du dein aus PP gespeichertes PNG wieder in PP öffnest und mit der Pipette misst solltest du 0,0,0, haben.

Somit vom mir  [Bild: c045.gif]

Gruß
Norre
Zitieren



Möglicherweise verwandte Themen...
Thema Verfasser Antworten Ansichten Letzter Beitrag
  Loch im Bild Roli 2 370 31.03.2018, 16:03
Letzter Beitrag: Roli
  Bild verformen canis 7 757 20.11.2017, 21:04
Letzter Beitrag: skifan
  Unebenheiten im Bild Luisa 11 1.000 19.04.2017, 10:10
Letzter Beitrag: swizzly
  Bild begradigen und zuschneiden Kellykiller 2 750 18.04.2016, 16:34
Letzter Beitrag: Kellykiller
  Schwarz/Weiß Bild und Farbe Tüfftele 10 2.174 03.06.2014, 21:29
Letzter Beitrag: Tüfftele
  Räteselhaftes Quadrat im Bild? (Photopaint X4) Karola 12 2.125 11.12.2013, 13:06
Letzter Beitrag: Karola
  Photopaint öffnet für jedes Bild wieder neu! schabronski 3 940 30.11.2013, 04:17
Letzter Beitrag: koter
  Bild wird nur teilweise Exportiert anorak 6 873 07.08.2013, 11:20
Letzter Beitrag: anorak
  VBA - Bild komprimieren Kosh 10 3.792 15.06.2013, 11:30
Letzter Beitrag: koter
  Bild in BIld einfügen Jakob1980 8 1.247 24.04.2013, 11:57
Letzter Beitrag: morphsuite